Relocating base directory Enterprise Manager’s central agent

Job Oprel 3

After the upgrade of the 12c central agent to 13c, I noticed the new central agent’s home located under the wrong – old agent – directory: /u01/app/oracle/agent12c/agent_13.2.0.0.0. Must have done something wrong. How to correct this? Want to move the directory to /u01/app/oracle/agent13c/. A very short blog to describe the two steps.

It’s a bit hidden away in the documentation (in the appendixes) but there’s a special procedure to do this, and it worked like a charm for me.

So, /u01/app/oracle/agent12c/agent_13.2.0.0.0  should be /u01/app/oracle/agent13c/agent_13.2.0.0.0

Step 1:  Create a list of plugins by using this command:

/u01/app/oracle/agent12c/agent_13.2.0.0.0/perl/bin/perl      /u01/app/oracle/agent12c/agent_13.2.0.0.0/sysman/install/create_plugin_list.pl -instancehome /u01/app/oracle/agent12c/agent_inst/

A file /u01/app/oracle/agent12c/plugins.txt is created, used by the next command.

 

Step 2: Creating a new base directory for agent13c – where I didn’t need to stop the agent by the way, that’s all included in the script:

/u01/app/oracle/agent12c/agent_13.2.0.0.0/perl/bin/perl /u01/app/oracle/agent12c/agent_13.2.0.0.0/sysman/install/AgentMigrate.pl -instanceHome /u01/app/oracle/agent12c/agent_inst -newAgentBaseDir /u01/app/oracle/agent13c

Post actions to be done:

  • Run root.sh from /u01/app/oracle/agent13c/agent_13.2.0.0.0/root.sh manually
  • Deinstall (rm -R) agent home /u01/app/oracle/agent12c/agent_13.2.0.0.0 manually

And that’s it! Sometimes life is easy.

Regardz..

 

Resources:

Moving the central agent base directory : https://docs.oracle.com/cd/E73210_01/EMUPG/GUID-C807B2F8-DA3A-4934-8C2E-7DFB63E9F65D.htm#EMUPG377

3 thoughts on “Relocating base directory Enterprise Manager’s central agent

  1. Hello, I have tried to run this after my 13.2 agent upgrade and I am receiving an error.
    Moving of /usr/local/oracle/product/12105/agent/agent_13.2.0.0.0/sbin failed
    I did the same thing you did above and I am not sure why it is not working. Would you happen to know what I could be doing wrong? Thank you!

    1. Without some more information it’s hard to figure out what could be wrong. It’s your central agent, not an agent on a target? And I think the /sbin don’t belong in the path you described. Shouldn’t it be /usr/local/oracle/product/12105/agent/agent_13.2.0.0.0 instead of /usr/local/oracle/product/12105/agent/agent_13.2.0.0.0/sbin ?
      Regardz

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Next Post

Deploying Oracle OEM agents 13c on windows targets (2008 R2) while OMS is on Linux

Facebook0TwitterLinkedinSituation at customer’s site: OMS 13.2 on Oracle Linux, targets are Windows machines, and a bit ancient: Windows 2008 R2. How to deploy agents on those targets? Several methods are possible in theory. In this blog I’ll describe my efforts to determine what is really possible and what is efficient. […]